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This document briefly describes the features included in the RSE Extensions for WDSC 6.x and
higher.

If you are somewhat familiar with WDSC and its Remote Systems Explorer (RSE), these
screenshots should help make the added features fairly obvious to you. If you are not familiar
with RSE, then as you become more familiar with using WDSC you should find that these
extensions just naturally fall in line with everything else within WDSC. The following

screenshot is an example of how WDSC will likely appear when you restart it after installing the
RSE Extensions.
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RSE Extensions for WDSC 6.x and Higher

Notice that there are new subsystems for spooled files and messages beneath your iSeries

connection. These subsystems look and behave similarly to the other connection subsystems that
WDSC contributes.

OVERVIEW

The RSE Extensions consists of these primary features:

e The ability to manage and view iSeries spooled files.

e The ability to manage and view iSeries messages.

e A new "perspective"” that is optimized for source editing.

e Graphical compare and merge editors for iSeries source code.

e A custom editor for editing the contents of data areas.

e A custom dialog for displaying the properties and contents of data queues.

A description of each feature follows.
WORKING WITH SPOOLED FILES

The RSE Extensions adds a subsystem named iSeries Spooled Files to your iSeries connections.
This subsystem will initially include one filter -- Your spooled files -- that shows you all the
spooled files associated with the user profile the connection is using to access the iSeries

computer. The filter delivers results equivalent to running the WRKSPLF command on a 5250
command line.

The following screen shows the filter in the Remote Systems Details table view. It also shows a
spooled file that has been opened in the built-in text editor.
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RSE Extensions for WDSC 6.x and Higher

You can create custom filters in the spooled files subsystem just as you can in other RSE
subsystems:

@New

Spooled File Filter

=
Create a new filker to list spooled files _’

User: ’*7
Cukpuk queus: W

Library: W
User data: ’*7
Farm kype: ’*7

ext = | | Cancel ‘

All of the standard options for managing spooled files are available for use in the expanded
filters.

Because this feature is intended to make it easier for a developer to access compile listings and

job logs without leaving the IDE, the ability to view and access more complicated spooled files,
such as *AFP with overlays, is very limited.

WORKING WITH MESSAGES

The RSE Extensions also adds a subsystem for iSeries Messages. As with the spooled files
subsystem, it implements a standard RSE subsystem that allows you to define filters for
messages. A default "Your Messages" filter is created automatically. In addition to these
features, which require no additional explanation, there is one other unique feature implemented,
and that is the ability to have WDSC monitor your personal message queue in the background
and notify you of new messages. Right click on the iSeries Messages subsystem and choose
Properties, then click on Message Queue Monitoring. A screen like this appears:

(& Properties for iSeries Messages -. X

Cornrnand Execution

Initial Library List

Message Queus Monitoring
Subsystem

Message Queue Monitoring

¥ IMonitor message queus

v Remove informational messagss after notification

Inquiry message notification: Dialog -
InfFormational message notification: |eMail o

eMail; |vDuraddress@yourcompany.com\

From: | Message Queus Manitar

Host: | mailserver, yourcompany, com
Part: 25
Test
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RSE Extensions for WDSC 6.x and Higher

Initially, the Monitor Message Queue checkbox is not checked, so the remaining settings do not
appear. The settings are self-explanatory; you are indicating how you want WDSC to handle the
various types of messages you receive. If you receive an Inquiry message, WDSC can present a
dialog that lets you respond to the message without leaving the IDE.

ISERIES EDITING PERSPECTIVE

The iSeries Editing Perspective provided by the RSE Extensions is a new perspective you can
switch to when editing source. This feature is mainly a convenience feature. WDSC is very
flexible in how you arrange your windows. It also lets you save those arrangements as your own
perspective. All we have done is take the best practices we have learned over the years and
package those settings up for you. This also allows us to do the one thing that you cannot do
yourself, which is give the perspective a unique icon. This makes it easier to visually recognize
in the list of open perspectives. Here is a quick description of how to use this perspective:

Open some source

First, open a couple of members for editing in RSE. This will make it easier to see the
perspective's features.

Open the Perspective

To open the perspective for the first time, do Window » Open Perspective » Other. A screen like
this appears:
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RSE Extensions for WDSC 6.x and Higher

Select the iSeries Editing perspective. Note that once the perspective is open, it is easy to quickly
switch between open perspectives. Just use the perspective switcher that appears in the top-right
hand corner of WDSC (visible in the next screen). The perspective looks like this:

@ iSeries Editing - CHGOBJ.RPGLE - IBM Ratianal Software Development Platform ==&
File Edit Source Comple Mavigate Search Project Run  Window Help
] = Q- o E A E BB B [ | [ 15eries Editing =
P OHGIFSATRRPGLE | 7 CHEOB1,RPGLE 50 B
Line 1 Column 1 Replace
B T N IR I R T T T RN IR AT - T
000121 /TITLE ChgObj - Change object CPP. |
oo0o0zoo R A T T T
000300 * Copyright (C) 2001 David M. Morris
oo03oz % This file i= part of the iSeries-toolkit
000303 * The iSeries-toolkit is free software; vyou can redistribute it and/or
000304 * modify it under the terws of the GNU General Public License wersion 2,
0003058 * @z published by the Free Zoftware Foundation.
ooo0306 * The iseries toolkit is distributed in the hope that it will be useful,
00307 # put WITHOUT AMY WARRAWNTY: without ewven the implied warranty of
oo030s * MERCHANTABILITY or FITNESS FOR L PARTICULAER PURFOSE.
nlaluiclul=] * Bee the GNU General Public License for wore details.
000310 i
000311 * ¥ou should have received a copy of the GNU General Public License
ooo031z # glong with this file; if not, write to the Free Zoftware Foundation,
000313 * Inc., 59 Tewple Place, Suite 330, Boston, MA 02111-1307, U3Ah.
000314 * ¥You might find & version at http://www.gnu.org/ licenses/gpl.txt
000315 i
000316 *  Module - ChgOh)
000400 * By - David Morris
000500 * Purpose - Command processor for CHGOBJ commancd.
O0o0&00 * Cowpile - CRTRPGMOD MODULE {objlib/CHGOBJ) =
<] »
|
o Al &Y

It may not look like much, but that is the point. As you may already know, when you double
click an editor or view in any window it will expand, or "maximize," to fill the whole space.
However, when a window is maximized you can see only one window at a time. So instead of
forcing you to maximize, this perspective condenses the extra views into a set of toolbar icons at
the bottom, allowing the editors to use the entire screen:

@ iSeries Editing - CHGOBJ.RPGLE - IBM Rational Software Development Platform ==k
File Edit Source Comple Mavigate Search Project Run  Window Help
] = Q- o E A E BB B [ | [ 15eries Editing =
/CHGIFSF\TR.RPGLE b m]
Line 58 Column 1 Replace
. . DMame +++++++++++ETDsFrom+++To/ L+++IDc . Keyword: oI
00g100 I PC3ys 101 0 CONST A:
Oo0&=200 D PCAre 10T 0 CONST
00g300 I Syskrc 101 0 CONST
Do6400 R ]
006402 * Define work wariables ¥
006403 R ]
oDg404 DErr 3 u INZ(*OFF) M
a >
 CHGOB,RPGLE £ 0
Line 99 Column 1 Replace
| Eooooons I - DO S - A S T Y -
007941 C ChiTyp) A
007942 Cc+
007543 C* While no errors, list incomplete or records being returned.
007944 C Dow LIst=s <> '3' LND
007945 & (LISts <+ '2' OR
007946 C LIcnt > LIFstRod + LIRtnCnt)
DD?B‘{?I C* Get next batch of records if not at end. hdl
e Ed
ot 6 i B &
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RSE Extensions for WDSC 6.x and Higher

Notice how you can now see two members at the same time. Again, you could always do this,
but when you are trying to do it at the same time that other views are showing, it is not very
helpful. With the extra screen real estate this feature now becomes useful. If you are not aware of
how to do this, just click and drag one of the editor tabs to any window edge. The icon changes
so you know when to drop the Window. To undo the effect, just drag and drop onto another
editor pane, and WDSC will go back to stacking them.

At this point, you might be saying, "OK, but I need some of those views, like the Outline view,
or the Remote Systems view." Remember those icons we mentioned, on the bottom toolbar in the
previous screenshot? Those are all of the common views you would typically need to access. In
this case, we have converted them to something WDSC calls a "Fast View." Click the icon for
the Outline view. Your screen now looks something like this:

(@ iSeries Editing - CHGOBJ.RPGLE - IBM Rational Software Development Platform =JoEd
File Edit Source Comple Mavigate Search Project Run Window  Help
i Q- & - A T | [ iseries Edting 2
£Z Outline 22 gh =8 =
= C*’;« Global Defiritions Replace
+ Cﬁ Data Structures -+ETDsFrom+++To/ L+++IDc . Reywords++++++++++++++++++t =i}
-3 Indicators 101 0 CONST A~
i Fields 101 O CONST
w-L Constants 10I O COMST
+ lY%Prototw:nes IEEEEEAARANT
- Main Procedure varisbles *
=l |3 Parameters EEERERFRRAT
0 obiLib : Character (20) 5 N INZ{%OFF) -
cI: ObiTyp : Character (7) 3

cI: Srclib : Character (10}
cI: SrcFil : Character {10)

cI: SrcMbr : Characker (10)
cI: Tzt i Character {500 B
cI: UsrDFnatr : Character {100

Replace

1080 05°0 0 0 A6 6 0 05 P 6 6 65 0 08 0hro 0 6 0sa 8 0 09,0 8 0 A0 0 0 65 Pa 6 0 o o 00 oA ro 06 o=lo 6 o o
ChiTyp) ~
rors, list incomplete or records heing returned.
Diow LIZt= <> '3 AND
(LIZt= <= '2' OR
LICnt > LIFstRed + LIRtnCnt)

:zh of records if not at end. b
| »

EdAlw TR

Notice how the view "slides™ into place on top of your editors? In the case of the Outline view,
you can expand the outline and click on a field's or procedure name's line number. This takes you
to that part of the source, and the Outline view slides back out of sight. (You can also click the
minimize button in the view, or click back in your editor, to close the view.) Of course, the
perspective switcher makes it easy to just switch back to your other perspective to access to the
views there. Perspectives, and fast perspective switching, are among the main architectural
features in the Eclipse-based IDEs.
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RSE Extensions for WDSC 6.x and Higher

(@ iSeries Editing - CHGOBJ.RPGLE - IBM Rational Software Development Platform =oEd
File Edit Source Compile Mavigate Search Project Run Window  Help
B9~ Q- | (=10 E | [ iseries Editing 2
0F Outline £ &b =0 =]
= C:,L Global Definitlans Replace
+ CD Diaka Struckures -+ETDsFrom+++To/ L+++1D0c . Eeywords+++++++++++++++++ -+ oo
+ [ Indicstors 10I O CONST A~
# fi= Fields 10I 0 CONST
#L5 constants 101 0 CONST
+ :L'-i}g Pratotypes R R R R AR AR
= % Main Procedure variables *
= | Parameters PEEREEEEEEEN
1 obiLib : Character (20) 5 N INZ{%OFF) =
1 objTyp : Character (71 5|
L‘]:ZI Zrclib ¢ Character (100
1 =rcFil : Character {10}
CI:I Srcbr ¢ Character (100
01 Tt : Character (50) B
EI:I UsrDfnatr : Character {10} 1
Replace
b T L B L R R L DB S e R B SR TSR S B
Ob3Typ) i
;ors, list incomplete or records being returned.
Do LISts <» '3' ILND
[LISt= <> 'Z' OR
LICht » LIFstRcd + LIRCnCnt)
Lol et records df notratend, hdl
\ >
o Al B

GRAPHICAL COMPARE/MERGE EDITORS

The RSE Extensions provide a graphical compare/merge editor
for iSeries source code. These editors are built on top of the
powerful compare/merge features that are provided with Eclipse
for Java source code. The RSE Extensions handles retrieving and
locking your source member from your iSeries source file. It then
has to strip the first 12 source file bytes (sequence and date) from
the local file so that the Eclipse compare engine can properly
analyze the differences of the files. When you save your changes,
the source is put back in the source file and the lock released.
The sequence and date fields in the member are reset to new

To access these editors, right-click on the member in your
development source file and choose RSE Extensions » Compare
or Merge, depending on the action you want to perform.

GoTo ¥
Open With 4
Browse With 4

I. Rename...

=] Copy

+}» Move...

¥ Delete...
Web Services 4

B Find String...

=" Verify

24 Verify (Prompt)... .

W values as part of this process.
Compile 4
Compile (Prompt) 4
User Actions 4
Add To iSeries Projecs...
Make Available Offline
TurnOver Actions k.
RSE Extensions 4 Compare...
Debug({Service Entry) »| Merge..,
Compare With 4
Properties(1)
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RSE Extensions for WDSC 6.x and Higher

You will be presented with one of these dialogs, depending on which option you choose.
Error! Objects cannot be created from editing field codes.

The values you enter into these dialogs are fairly self-explanatory, especially if you have used
PDM option 54 and 55. A notable enhancement to those options, however, is that each source
member can come from a different iSeries system. This is because the members are just retrieved
and compared on your local workstation. Once you click OK, the members are downloaded and
compared and opened in the Eclipse compare or merge editor.

| £° compare T54PRDS/QRPELESRC(TURRFORS) to DAVIE/QRPGLESRC(TURRFORS) 5 ]
/T&xtCumparE 7! & 4
Exsr CvtOper: Exsr CvtOper: ~
SglWhere = $TRIMR (SglWhere) + ' SglWhere = $TRIMR (SglWhere)
£TRIMR (Operand) + ' | { Operand + ' ' + %
TndIs; I Tndlf; [
IF S5CmpLev <» *BLANKS: IF S5CmpLev <> *BLANKS:
*IN6D = *ON; *IN&D = *ON;
CperIN = SCmpLev; CperIN = SCmplev;
Ex=sr CvtOper; Exsr CvtOper;
SglWhere = $TRIMR (SglWhere) + °' S5glWhere = ITRIMR (SglWhere)
'%I'RiM?'\thpezand'] PR C‘perand + ' ' 1 %
EndIf; EndIf;
I1f pUpdateMode <> '"*BYTASK'; ] IF SCmpRef# <> *BLANKS;
IF SCmpRef# <> *BLANKS: l *IN&0 = *ON;
*INED = *ON; ope SCmpRefi;
Exsr CwvtCper
Exsr CvtOper; S5glWhere = 3TRIMR (SglWhere)
SqlWnere = 3TRIMR (SglWnere) + { - Cperand + ' ' +
$TRIMR (Operand) + EndIf; I
EndIf;
Endif: | IF SCmpPomr <> *BLANKS:
I *INGO = *ON;
IF 5CmpPgmr <> *BLANKS; CperIl
*IN6D = *ON; Exsr CvtOper:
CperIN = SCmpPgmr; SglWhere = $TRIMR (SglWhere)
Exsr CvtOper; 1 o Ope.‘r‘ar;d |
SglWhere = $TRIMR (SglWhere) + *' ] EndIf; )
STRIMR (Operand) + '
EndIf; IF S5CmpSts <> *BLANKS: .
*IN&0 = *ON; .
£ ¥ £ b

The editor contains all of the same compare/merge features that you get when using it for Java
source. The only negative to the editor is that it is not "aware" of the iSeries languages you are
comparing/merging. So you do not get the color-coding or other editor features you get when
using the LPEX editor. Hopefully, when/if IBM provides these features as part of WDSC itself,
those editor features will be available in their implementation.

CHANGE DATA AREA

The RSE Extensions provides a custom dialog for editing data areas. Just right-click on a
*DTAARA object and choose RSE Extensions » Change Data Area. This brings up a dialog that
shows the data area attributes and lets you edit the contents. This can be particularly useful for
data areas with lots of text that you want to edit.
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RSE Extensions for WDSC 6.x and Higher

-,

© Change Data Arca =]

—Data area: @ {Ih-imge Dﬁtﬂ .hl'E\-ﬂ E

Mame: ITJT"I-UU
~Data area:
i ' i I—
Library: iTURN._LSD S| e
Type: [ o Library: [ TURNSLSD
—Value: Type: I"DEC

FQIEM/ProdDats/Java400/it400nty jar: /QIEM ProdData HT TP [ﬂ
fPublic/jt400 iib/jt400.jar: fQIBM,ProdDataHTTP Publicjt400/i | — | ~Value:
b fx4i400.jar: /QIBMProdData /HTTFPublic/it400/lib /data400.] E

ar I PO
[v] OK I Cancel

-
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DISPLAY DATA QUEUE

The RSE Extensions provides a custom dialog for displaying data queues. Just right-click on a
*DTAQ object and choose RSE Extensions » Display Data Queue. This brings up a dialog that

shows the data queue attributes and also a preview of the first entry in the queue.

@) Display Data Queue

Data queue: -
MName: :3.405240001

Library: TURNSLS

Description: | Response Data Queue

Attributes:

Type of data quewe: W
Sequence: J?
Maximum message length: 1024

MNumber of messages in queue: Jl—
Number of entries currently allocated: ]16—
Maximum number of entries allowed: W
Initial number of entries: Jlﬁi
Maximum number of entries specified: ]W

[ Indude sender ID [ Force to auxilary storage | Automatic reclaim

Preview of first message:

FORM 0118449

Application: MWNG/00,/00/10

.

Form: 0118449 was created for

Cancel Refresh
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RSE Extensions for WDSC 6.x and Higher

UPDATING THE RSE EXTENSIONS

Newer versions of WDSC have a feature in the Preferences that you can set to automatically
check for updates. You can use this feature to update your RSE Extensions as long as you are not
behind a proxy server that does not allow this activity. You can check for updates manually by
choosing Software Updates » Find and Install from the Help menu. Follow the instructions
provided by the wizard.

If you are behind a proxy server that will not allow WDSC's Updates feature to work, then you
can install updates by downloading and installing the latest version, as described above. When
you do this, the installer detects that the RSE Extensions are already installed and skips most of
the wizard screens.

© 2007 SoftLanding Systems, Inc. Release 6.1.1 Page 11

Jun-06



	RSE EXTENSIONS FOR WDSC 6.X AND HIGHER
	OVERVIEW
	WORKING WITH SPOOLED FILES
	WORKING WITH MESSAGES
	ISERIES EDITING PERSPECTIVE
	Open some source
	Open the Perspective

	GRAPHICAL COMPARE/MERGE EDITORS 
	CHANGE DATA AREA 
	 DISPLAY DATA QUEUE 
	 UPDATING THE RSE EXTENSIONS


